4.1 While Loop | 4.2 For Loop | 4.3 String Iteration | 4.4 Nested Iteration | Unit 4 Quiz |
Unit 4 - HW Quiz
Unit 4 Team Teach HW QUIZ
Unit 4 - Iteration:
- This is the homework quiz for unit 4, iterations
- 4 multiple choice questions
- 2 programming hacks
- 1 bonus programming hack (required to get above 0.9)
Question 1:
What does the following code print?
A. 5 6 7 8 9
B. 4 5 6 7 8 9 10 11 12
C. 3 5 7 9 11
D. 3 4 5 6 7 8 9 10 11 12
Click to reveal answer:
DExplain your answer. (explanation is graded not answer)
for (int i = 3; i <= 12; i++) {
System.out.print(i + " ");
}
It would print D becuase it starts with 3 and it’s “i=3” and then it would keep adding 1 until it gets to 12 becuase it says <= to 12.
Bonus:
- Explain the difference between using a variable like i inside a for loop, vs. using a variable that exists in the code itself for a while loop
Question 2:
How many times does the following method print a “*” ?
A. 9
B. 7
C. 8
D. 6
Click to reveal answer:
CExplain your answer. (explanation is graded not answer)
for (int i = 3; i < 11; i++) {
System.out.print("*");
}
It’s C because it prints out 8 times because if it starts with 3 it would print an astrik until it hits 10.
Question 3:
What does the following code print?
A. -4 -3 -2 -1 0
B. -5 -4 -3 -2 -1
C. 5 4 3 2 1
Click to reveal answer:
AExplain your answer. (explanation is graded not answer)
int x = -5;
while (x < 0)
{
x++;
System.out.print(x + " ");
}
A because it continuously adds 1 to it; nevertheless, it stops at 0 because x is no longer less than 0.
Question 4:
What does the following code print?
A. 20
B. 21
C. 25
D. 30
Click to reveal answer:
BExplain your answer. (explanation is graded not answer)
int sum = 0;
for (int i = 1; i <= 5; i++) {
if (i % 2 == 0) {
sum += i * 2;
} else {
sum += i;
}
}
System.out.println(sum);
B because 21 will be printed by the code. For each value of i, the addition process starts at 1 and continues with 4 (double of 2) for i = 2, 3 for i = 3, 8 (double of 4) for i = 4, and lastly 5 for i = 5. There is a total of 21.
Loops HW Hack
Easy Hack
- Use a while loop to find the numbers from 1-50 that are divisible by 3 or 5, then store them into a list (make sure to print it out at the end)
- Use a for loop to do the same thing detailed above
public class Main {
public static void main(String[] args) {
ArrayList<Integer> divisibleBy3Or5While = new ArrayList<>();
int i = 1;
while (i <= 50) {
if (i % 3 == 0 || i % 5 == 0) {
divisibleBy3Or5While.add(i);
}
i++;
}
System.out.println("Numbers divisible by 3 or 5 (while loop): " + divisibleBy3Or5While);
}
}
Main.main(null)
Numbers divisible by 3 or 5 (while loop): [3, 5, 6, 9, 10, 12, 15, 18, 20, 21, 24, 25, 27, 30, 33, 35, 36, 39, 40, 42, 45, 48, 50]
public class Main {
public static void main(String[] args) {
ArrayList<Integer> divisibleBy3Or5For = new ArrayList<>();
for (int i = 1; i <= 50; i++) {
if (i % 3 == 0 || i % 5 == 0) {
divisibleBy3Or5For.add(i);
}
}
System.out.println("Numbers divisible by 3 or 5 (for loop): " + divisibleBy3Or5For);
}
}
Main.main(null)
Numbers divisible by 3 or 5 (for loop): [3, 5, 6, 9, 10, 12, 15, 18, 20, 21, 24, 25, 27, 30, 33, 35, 36, 39, 40, 42, 45, 48, 50]
Harder Hack
Palindromes are numbers that have the same value when reversed (ex: “123321” or “323”). Create a program that uses a while loop that outputs all palindromes in any given list.
Sample Input: test_list = [5672, 235, 5537, 6032, 317, 8460, 1672, 8104, 7770, 4442, 913, 2508, 1116, 9969, 9091, 522, 8756, 9527, 7968, 1520, 4444, 515, 2882, 6556, 595]
Sample Output: 4444, 515, 2882, 6556, 595
import java.util.ArrayList;
public class Main {
public static void main(String[] args) {
int[] testList = {5672, 235, 5537, 6032, 317, 8460, 1672, 8104, 7770, 4442, 913, 2508, 1116, 9969, 9091, 522, 8756, 9527, 7968, 1520, 4444, 515, 2882, 6556, 595};
ArrayList<Integer> palindromes = new ArrayList<>();
int i = 0;
while (i < testList.length) {
if (isPalindrome(testList[i])) {
palindromes.add(testList[i]);
}
i++;
}
System.out.println("Palindromes: " + palindromes);
}
public static boolean isPalindrome(int number) {
int original = number;
int reversed = 0;
while (number != 0) {
int digit = number % 10;
reversed = reversed * 10 + digit;
number /= 10;
}
return original == reversed;
}
}
Main.main(null)
Palindromes: [4444, 515, 2882, 6556, 595]
Bonus Hack (for above 0.9)
Use a for loop to output a spiral matrix with size n
Example:
Sample Input: n = 3
Output: [[1, 2, 3], [8, 9, 4], [7, 6, 5]]
public class SpiralMatrix {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
System.out.print("Enter matrix size n: ");
int n = scanner.nextInt();
int[][] matrix = generateSpiralMatrix(n);
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
System.out.print(matrix[i][j] + " ");
}
System.out.println();
}
scanner.close();
}
public static int[][] generateSpiralMatrix(int n) {
int[][] matrix = new int[n][n];
int value = 1;
int top = 0, bottom = n - 1;
int left = 0, right = n - 1;
while (top <= bottom && left <= right) {
for (int i = left; i <= right; i++) {
matrix[top][i] = value++;
}
top++;
for (int i = top; i <= bottom; i++) {
matrix[i][right] = value++;
}
right--;
if (top <= bottom) {
for (int i = right; i >= left; i--) {
matrix[bottom][i] = value++;
}
bottom--;
}
if (left <= right) {
for (int i = bottom; i >= top; i--) {
matrix[i][left] = value++;
}
left++;
}
}
return matrix;
}
}
SpiralMatrix.main(null)
Enter matrix size n: 1 2 3
8 9 4
7 6 5